Incident on third party service - FTN

Incident Report for Signicat

Resolved

This incident has been resolved
Posted Aug 26, 2025 - 21:42 CEST

Update

We are continuing to investigate this issue.
Posted Aug 26, 2025 - 21:41 CEST

Investigating

An incident is currently affecting FTN-OP. Our eID connection towards this 3rd party service is running but is not functioning properly as a result of their incident. We are in monitoring their progression towards resolution.
Posted Aug 26, 2025 - 21:22 CEST
This incident affected: eID Hub - eIDs (Finnish Bank eIDs (FTN)).