Excessive PEP and Beneficial Owners Screening Alerts
Incident Report for Signicat
Resolved
This incident has been resolved.
Posted Nov 11, 2024 - 09:42 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 11, 2024 - 09:42 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 11, 2024 - 09:41 CET
Investigating
We experienced an issue with PEP- and Beneficial Owners screening, which in some cases generated too many alerts. The issue has been corrected and we are currently investigating the impact of the issue.
If you have received an unusually high number of PEP alerts please reach out to Signicat support.
Posted Nov 11, 2024 - 08:00 CET
This incident affected: Ongoing Monitoring (Trapets).