Degraded performance FTN OP Bank

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 14:10 CET

Update

OP has confirmed that they are currently experiencing technical issues. We will continue to monitor their progress towards a resolution.
Posted Jan 15, 2026 - 12:53 CET

Update

We are seeing an increased successrate and are continuing to monitor the situation.
Posted Jan 15, 2026 - 11:11 CET

Monitoring

We are continuing to monitor their progression towards a resolution.
Posted Jan 15, 2026 - 10:09 CET

Identified

Our eID connection towards this 3rd party service is running but is not functioning properly as a result of their incident.

We are monitoring their progression towards resolution.
Posted Jan 15, 2026 - 09:30 CET
This incident affected: eID Hub - eIDs (Finnish Bank eIDs (FTN)).