Incident on 3rd party service - FTN (OP Bank)

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Feb 08, 2026 - 07:53 CET

Update

We are continuing to monitor this 3rd party incident with OP Bank.

The next update can be expected at 8 AM (CET) Sunday.
Posted Feb 07, 2026 - 23:13 CET

Monitoring

An incident is currently affecting FTN (OP Bank).

Our eID connection towards this 3rd party service is running but is not functioning properly as a result of their incident.

We are monitoring their progression towards resolution.
Posted Feb 07, 2026 - 21:43 CET
This incident affected: eID and Wallet Hub - eIDs (Finnish Bank eIDs (FTN)).