Degraded performance - Suomi.fi e-identification

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted May 20, 2026 - 13:19 CEST

Identified

We are currently observing degraded performance with Suomi.fi e-identification. Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.
Posted May 20, 2026 - 13:16 CEST
This incident affected: eID and Wallet Hub - eIDs (Suomi.fi e-identification).