Incident on 3rd party service - MitID

Incident Report for Signicat

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 11:55 CET

Update

We are seeing MitID performing as expected, we will continue to monitor before resolving the statuspage.
Posted Nov 20, 2025 - 11:38 CET

Monitoring

An incident is currently affecting MitID, this is affecting integrations on id.signicat.com and api.signicat.com endpoints.

Our eID connection towards this 3rd party service is running but is not functioning properly as a result of their incident.

We are monitoring their progression towards resolution.
Posted Nov 20, 2025 - 11:31 CET

Investigating

We are currently observing degraded performance with MitID, affecting integrations on id.signicat.com and api.signicat.com endpoints. Incident response has been initiated and we are actively investigating the issue and working to restore normal operations.
Posted Nov 20, 2025 - 11:27 CET
This incident affected: eID Hub - eIDs (MitID).