Signicat Express Test Environment having problems
Incident Report for Signicat
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 10:08 CET
Investigating
The Signicat Bluestack Test Environment is having problems today.
Posted Jan 23, 2021 - 16:15 CET
This incident affected: Signicat Express (Former Idfy) (Signature, Identification, Deposit, Information services, Merchantsign, Secure Share).