ElectronicID unavailable
Incident Report for Signicat
Resolved
This incident has been resolved.
Posted Apr 09, 2021 - 13:28 CEST
Investigating
We are currently investigating this issue.
Posted Apr 09, 2021 - 12:24 CEST
This incident affected: Enterprise Identity Proofing (Assure API).