FTN Danske Bank's authentication service may currently be interrupted by some users.
Incident Report for Signicat
Resolved
Danske Bank's authentication service is back to normal.
Posted Mar 25, 2020 - 13:22 CET
Investigating
The issue is being investigated by the provider
Posted Mar 25, 2020 - 11:54 CET
This incident affected: Enterprise eID methods (Finnish Bank eIDs (FTN)).